INC-000000613 - Virgin Media Outage

Incident Report for ITS Technology Group

Monitoring

We are seeing services restored to impacted services. Please retest and let us know if you are still experiencing issues. We will continue to monitor whilst we await confirmation from the supplier this has been fixed
Posted Mar 30, 2026 - 17:17 BST

Update

Please see the latest from the supplier:

We can advise that we're continuing to investigate the issues seen on the TX Link at Haringey.

No issues seen at Dalston as advised by our Engineer from testing the fibres and we can confirm the Optical Alarm is not showing any further issues on Hayes TX Link at present but we're continuing to monitor and we have requested an Engineer to attend Hayes site to OTDR the fibres.

Our Technical Teams are analysing the Fibre System NNI link impacted by the fault in conjunction with our Engineers to pinpoint the issues further.

We can advise that further OTDR Testing will be carried out by our Engineer from Hayes to identify a suspected fibre break.

Next update 6pm.
Posted Mar 30, 2026 - 16:46 BST

Investigating

We are aware of an outage affecting multiple circuits on the Virgin Media network.

We have raised this to the carrier and they are actively investigating this issue.

Next update: 15:00
Posted Mar 30, 2026 - 14:02 BST
This incident affects: Off Net Providers (Virgin Media Business).