Major Service Outage (local)

Incident Report for ITS Technology Group

Resolved

Issue has been resolved, all services are back online
Posted Aug 01, 2025 - 08:57 BST

Update

Our engineers are working on site now to bring the services back online.
Posted Aug 01, 2025 - 08:05 BST

Identified

Our engineer is on their way to the source of the issue at the local telephone exchange to investigate and implement a fix.
Posted Aug 01, 2025 - 07:14 BST

Investigating

MSO Ticket Reference : We are currently experiencing an incident impacting customers in the Hammersmith area. Preliminary investigations are underway with our engineers to determine the root cause of this network incident. At this stage we are unable to issue an ERT until our engineers have completed further diagnostics.
Posted Aug 01, 2025 - 02:22 BST
This incident affected: Networks (West London).