LYE - total loss of service

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 11:56 GMT

Monitoring

We are seeing service restored to all remaining services.
Posted Feb 25, 2026 - 12:41 GMT

Update

1100 - Engineers remain on site working to bring the remaining services live
Posted Feb 25, 2026 - 10:58 GMT

Update

We are seeing most of the impacted services restored. work is continuing to bring the remaining services live next update 1100
Posted Feb 25, 2026 - 09:56 GMT

Update

Our engineers are currently on site and have identified an issue with the fibre. They are currently working towards restoring all services.
Posted Feb 25, 2026 - 02:29 GMT

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 25, 2026 - 02:28 GMT

Investigating

We are currently investigating a total loss of service for customers in the LYE area.
Posted Feb 24, 2026 - 23:14 GMT
This incident affected: Networks (Lye Exchange).