INC-000000671 - Birmingham (Bromford Lane)

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 00:24 BST

Monitoring

Our router had overheated and shut down, we have brought the temperatures down and have repositioned the device to allow for a better climate. We will continue to monitor.
Posted Jul 09, 2026 - 20:24 BST

Update

Our engineer has arrived on site and is investigating the issue.
Posted Jul 09, 2026 - 19:29 BST

Update

Our engineer is on their way to the affected node, ETA is 19:30
Posted Jul 09, 2026 - 18:47 BST

Investigating

We are seeing one of our network routers down in the Bromford Lane area of Birmingham causing a total loss of service for all customers in the area. We have allocated engineers to attend and are awaiting an ETA.
Posted Jul 09, 2026 - 18:16 BST
This incident affected: Networks (Birmingham).