Partial Service Outage - Brighton

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 22:11 GMT

Monitoring

1730 a fix has been implemented and we are seeing services restored.
Posted Dec 01, 2025 - 17:32 GMT

Update

The engineers onsite have identified the location of the issue and are working on resolving the fault. Next update will be provided by 18:30
Posted Dec 01, 2025 - 16:31 GMT

Update

1430 Engineers onsite are continuing to investigate this issue. next update 1530
Posted Dec 01, 2025 - 14:27 GMT

Update

1330 - Engineers have arrived onsite and currently investigating the fault.
Posted Dec 01, 2025 - 13:30 GMT

Investigating

We are aware of an issue impacting a very small number of customers in the Brighton Area. Engineers will be on site in the next 15 minutes to investigate. next update 1400
Posted Dec 01, 2025 - 13:22 GMT
This incident affected: Networks (Brighton).