INC-000000667 - Blackburn Outage

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 09:38 BST

Monitoring

We are seeing services restored. Please retest and let us know if any issues persist. We will montior this for a period
Posted Jul 06, 2026 - 14:48 BST

Update

Our engineers are still on site carrying out the necessary works to bring services live.

Next update 14:30.
Posted Jul 06, 2026 - 13:35 BST

Update

Our engineers remain on site at the fault location carrying out investigations and repairs.

Next update: 13:30
Posted Jul 06, 2026 - 12:30 BST

Identified

Our engineers have identified the fault and have begun repair work.

Next update 12:00.
Posted Jul 06, 2026 - 11:01 BST

Investigating

We are aware of an issue impacting a small number of customers in the Blackburn area. We currently have an engineer on site investigating the issue.

Next update 11:00.
Posted Jul 06, 2026 - 10:09 BST
This incident affected: Networks (Blackburn & Accrington).