Major Service Outage (local) - Islington

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 21:19 GMT

Monitoring

A fibre fault has been fixed in a nearby SP, all services are back online. We are monitoring the connections to make sure they are all stable again.
Posted Mar 17, 2026 - 21:13 GMT

Identified

MSO INC-000000607 : We are currently experiencing an incident impacting some customers in the Islington area. We have engineers on site currently investigating the issue
Posted Mar 17, 2026 - 21:00 GMT
This incident affected: Networks (Islington).