INC-000000534 - Packet loss to Microsoft IP addresses and websites

Incident Report for ITS Technology Group

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2025 - 12:34 BST

Identified

The issue has been identified as a microsoft issue. We have diverted traffic away from our microsoft peering links and have seen an improvement. We believe this should resolve all issues. We will re-establish microsoft peering links once we're happy they've resolved their issue.
Posted Oct 07, 2025 - 12:42 BST

Update

We believe this to be part of a wider issue with Microsoft. We have raised this with them and are awaiting a response.
Posted Oct 07, 2025 - 12:38 BST

Investigating

We are currently aware of ongoing issues involving packet loss when connecting to Microsoft IP addresses or websites.

Our network engineers are actively investigating the issue, and we will provide an update as soon as more information becomes available.
Posted Oct 07, 2025 - 12:35 BST