Partial Service Outage PXC

Incident Report for ITS Technology Group

Resolved

We can now see that traffic is restored for the effected services. This incident is now resolved.
Posted Feb 24, 2026 - 18:08 GMT

Update

1150 - The core network team have restored services for some customers and the team are working actively to restore the remaining customers as quickly as possible
Posted Feb 24, 2026 - 12:00 GMT

Identified

An Initial fix was implemented however some circuits are still showing as offline. The supplier has escalated this internally to the Engineering team. next update 1130
Posted Feb 24, 2026 - 10:31 GMT

Investigating

We are currently seeing an outage on the PXC network impacting some customers. We are liaising with the supplier. Next update 1030
Posted Feb 24, 2026 - 09:36 GMT
This incident affected: Off Net Providers (PXC).