Birmingham (Bromford Lane) - Outage

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 17:33 BST

Monitoring

Service has now been restored in the Bromford area following the work carried out by our engineering team.

We apologise for the disruption and thank you for your patience and understanding while we worked to restore services.

Please retest your service and let us know if you continue to experience any issues.
Posted Aug 18, 2026 - 19:33 BST

Identified

We are currently experiencing a service outage affecting services in the Bromford area. We have initiated emergency maintenance to address the issue and restore service as quickly and safely as possible.

Our engineering team is actively working to resolve the issue. We apologise for the disruption and appreciate your patience while we work to restore service.

We will provide another update as soon as we have more information.
Posted Aug 18, 2026 - 18:34 BST
This incident affected: Networks (Birmingham).