INC-000000630 - Derby outage

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted May 06, 2026 - 15:53 BST

Monitoring

We are seeing services restored following our engineers works, the issue was related to power at the exchange. Please retest your services.

We will monitor for a period to make sure there is no further issues.
Posted May 06, 2026 - 11:10 BST

Investigating

We are aware of an issue in the Derby area affecting multiple circuits.

Our engineer is currently on route to the exchange and will be arriving at 09:45 to begin investigations.

Next update: 11:00
Posted May 06, 2026 - 09:33 BST
This incident affected: Networks (Derby).