Partial Service Outage - Brighton

Incident Report for ITS Technology Group

Monitoring

Engineer has completed splicing works and has brought the impacted customers online. We will now monitor for further issues.
Posted Mar 31, 2026 - 07:11 BST

Update

Our engineer has restored service to the Fibre Bright and Fibre Light services, they are now working on any remaining dark fibre cables.
Posted Mar 31, 2026 - 01:23 BST

Update

Work is still ongoing at site to resolve the issues. We will provide further updates when available as the engineers work through the night.
Posted Mar 30, 2026 - 22:07 BST

Update

Our field engineering teams have arrived back onsite to address the damaged cabling.
Posted Mar 30, 2026 - 19:00 BST

Update

Engineers are on route. The next update will be to confirm the Engineers have arrived onsite and work is underway
Posted Mar 30, 2026 - 17:13 BST

Identified

Engineers are due on site to repair cable at 1800
Posted Mar 30, 2026 - 15:34 BST

Investigating

We are currently experiencing an issue that is impacting a small number of Customers in the Brighton Area. Engineers have attended site and identified the issue. We are sourcing a support team to site
Posted Mar 30, 2026 - 14:47 BST
This incident affects: Networks (Brighton).