INC-000000669 - Faraday outage

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 15:52 BST

Monitoring

We are seeing all services being restored. Please retest and let us know if any issues persist. We will continue to monitor the service for a period
Posted Jul 08, 2026 - 11:03 BST

Identified

Our Network Engineering team has identified the issue and the majority of services have now been restored. They continue to work on restoring any remaining affected services.
Posted Jul 08, 2026 - 08:12 BST

Update

Our Network Engineering team continues to investigate the remaining service impacted and are working to restore affected services. We will provide further updates as they become available.
Posted Jul 08, 2026 - 07:11 BST

Investigating

Following tonight’s planned migration, a number of customers remain impacted.

Engineers are onsite working with our Level 4 engineering team to restore services. Further updates will be provided as they become available.
Posted Jul 08, 2026 - 06:04 BST
This incident affected: Networks (Faraday).