INC-000000673 - Scunthorpe

Incident Report for ITS Technology Group

Monitoring

Our engineer has identified the source of the power fault and fixed it, we are seeing all devices and services back online.
Posted Jul 12, 2026 - 15:58 BST

Identified

Our engineer is on site now and investigating the issue. It appears to be a power fault associated with our OLTs, more updates to follow.
Posted Jul 12, 2026 - 15:43 BST

Update

Our engineer is on their way to the affected exchange, ETA is 1 hour.
Posted Jul 12, 2026 - 12:56 BST

Investigating

We are currently investigating an issue in Scunthorpe, we have lost comms with some of our equipment there causing a total loss of service for some customers in the area. We are dispatching an engineer to investigate.
Posted Jul 12, 2026 - 11:08 BST
This incident affects: Networks (Scunthorpe).