Partial Service Outage - Hyde

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 09:56 GMT

Monitoring

1120 - a temporary solution has been applied, and we can see service has been restored for the impacted customers. We will continue to monitor this issue
Posted Feb 24, 2026 - 11:25 GMT

Investigating

We are currently experiencing an Outage impacting multiple customers in the Hyde area, This looks to have been caused by fire damage. We have an engineer on site and we are currently assessing the situation
Posted Feb 24, 2026 - 10:53 GMT
This incident affected: Networks (Tameside).