INC-000000504 - Degraded performance affecting multiple circuits in the Derby area

Incident Report for ITS Technology Group

Resolved

Service stable after a period of monitoring. We are closing this incident.
Posted Jun 18, 2025 - 10:41 BST

Update

We are continuing to monitor for any further issues.
Posted Jun 18, 2025 - 09:46 BST

Monitoring

Openreach have repaired the fibre and we can see that service has now been restored, we will now monitor this and advise if we see any further issues.
Posted Jun 17, 2025 - 22:27 BST

Update

Engineers have arrived on site and have begun the repair work. Due to the size of the repair needed and the amount of time this will take to resplice, they have given the next update time as 09:00am in the morning.
Posted Jun 17, 2025 - 20:44 BST

Update

Our engineers identified a fibre break and arrived at the location and are now currently working on replacing the cable. Once the cable has been replaced, the engineer's will start splicing work, however due to the complexity it may take a long time to complete, and work is expected to continue into tomorrow.

Apologies for any inconvenience caused.

The next update will be at approximately 18:00
Posted Jun 17, 2025 - 15:40 BST

Investigating

We are currently aware of an issue in the Derby area affecting multiple circuits causing degraded performance such as slow speeds and packet loss.

Our engineers are currently at the exchange carrying out investigations.
Posted Jun 17, 2025 - 14:38 BST
This incident affected: Networks (Derby).