Partial Service Outage - Manchester

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 08:49 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2026 - 22:23 GMT

Update

Our Engineer has repaired the damaged fibre and fully restored service. We will further monitor the network before closing the incidence.
Posted Jan 27, 2026 - 22:22 GMT

Update

Our Field Engineers have identified the damaged cable, efforts are ongoing to repair the damaged fibre, next update will be 22:30
Posted Jan 27, 2026 - 21:13 GMT

Identified

We are identified another separate outage in the region that might be be affecting some customer, our Engineers are working on it. Next update will be 21:00
Posted Jan 27, 2026 - 20:09 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2026 - 19:38 GMT

Update

Kindly be informed that our Engineer has restored service, we can see services online. We are going to monitor the link for a period of time before we close the incidence ticket. If you are still experiencing any network outage on your network, kindly raise a ticket to our NOC using the standard process
Posted Jan 27, 2026 - 19:38 GMT

Update

Our Engineer are still on site working on the fix, next update will be 20:00
Posted Jan 27, 2026 - 19:24 GMT

Identified

1815 - Engineer has arrived on site and the location of the issue has been identified. we are working on a fix. next update 1900
Posted Jan 27, 2026 - 18:19 GMT

Investigating

We are experiencing a partial Outage in Manchester impacting a small number of customers. An Engineer is on route to site next update 6pm
Posted Jan 27, 2026 - 17:16 GMT
This incident affected: Networks (Manchester).