Major Service Outage - Mayfair

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 15:44 BST

Monitoring

Our engineers have carried out repair works on a fibre node. Services are operational. We will have a period of monitoring before marking this incident as resolved.
Posted Jul 29, 2025 - 10:59 BST

Update

The Engineers are on site and investigations are continuing. Next update 11.30
Posted Jul 29, 2025 - 10:35 BST

Investigating

We are currently experiencing an incident impacting some customers in the Mayfair area.

Preliminary investigations are underway with our engineers to determine the root cause of this network incident.

Another will follow around 10:30
Posted Jul 29, 2025 - 09:36 BST
This incident affected: Networks (Mayfair).