INC-000000668 - Manchester outage

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 09:38 BST

Monitoring

1500 - We are seeing services restored. Please retest and let us know if any issues persist. This will be monitored for a period
Posted Jul 06, 2026 - 15:07 BST

Investigating

We are aware of an issue impacting a small number of customers in the Manchester area. We currently have an engineer on route to site to carry out investigations.

Next update 14:30
Posted Jul 06, 2026 - 13:37 BST
This incident affected: Networks (Manchester).