INC-000000689 - Mayfair outage

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 12:12 BST

Monitoring

Our engineer has attended the Exchange and carried out a repair and we are now seeing the affected services back online.
Posted Aug 18, 2026 - 15:54 BST

Investigating

We have identified an outage in the Mayfair area affecting a number of customers.

We are currently arranging for an engineer to investigate at the exchange.

ETA to follow.
Posted Aug 18, 2026 - 14:52 BST
This incident affected: Networks (Mayfair).