Partial Outage - Hyde

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 15:31 GMT

Monitoring

Engineers have completed the repair works and we are now seeing all services back online. We will continue to monitor for a period of time.
Posted Nov 30, 2025 - 20:50 GMT

Identified

Engineers are completing repairs on the fibre and we are now seeing services begin to restore. The next update will be provided once the repair works are fully completed.
Posted Nov 30, 2025 - 19:24 GMT

Investigating

We are currently experiencing an incident impacting a small number of customers in the Hyde area. Preliminary investigations are underway with our engineers to determine the root cause of this network incident. Our engineers are currently on site investigating and we will update with their findings as we have more information available.
Posted Nov 30, 2025 - 19:05 GMT
This incident affected: Networks (Tameside).