INC-000000611 - Birmingham outage

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 17:38 GMT

Monitoring

Our field engineers have carried out a repair on the network and we are now seeing all services affected restored.

Please retest and reach out if you are experiencing any further issues.
Posted Mar 27, 2026 - 12:00 GMT

Update

Our engineers are on site at the fault location currently carrying out initial investigations.

Next update: 12:00
Posted Mar 27, 2026 - 11:01 GMT

Identified

We have identified an outage affecting customers in the Birmingham area. We have sent a request to our field engineering team to dispatch a team to the fault location.

Next update: 11:00
Posted Mar 27, 2026 - 10:10 GMT
This incident affected: Networks (Birmingham).