Partial Service Outage - Bishopsworth

Incident Report for ITS Technology Group

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 09:00 BST

Monitoring

1610 We are seeing all services restored. We will continue to monitor for a period
Posted Jul 01, 2026 - 16:10 BST

Update

1530 We are starting to see some services restored. Work continues to restore the remaining impacted services
Posted Jul 01, 2026 - 15:31 BST

Identified

1430 Engineers are onsite and have identified the damaged cables. Work is underway to swap the fibres to restore service
Posted Jul 01, 2026 - 14:25 BST

Investigating

We are aware of an issue impacting a small number of customers in the Bishopsworth area. An Engineer is currently on route to site
Posted Jul 01, 2026 - 12:55 BST
This incident affected: Networks (Bishopsworth).